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Using ENVI with HIiRISE Image Data

Introduction

What is ENVI and IDL?

ENVI is a desktop software program for remote sensing and raster GIS applications.
ENVI is the ideal software for the visualization, analysis, and presentation of all types
of digital imagery. Developed by leading researchers in the field, ITT Visual
Information Solutions' ENVI provides a complete remote sensing package with the
most advanced and user-friendly image processing tools. ENVI's intuitive and
customizable graphical user interface allows you to start processing your data
immediately.

ENVI’'s underlying language IDL (the Interactive Data Language) is fully accessible
allowing you to customize ENVI to meet your specific requirements. IDL is an
interpreted computer language and interactive software environment that is ideal for
data analysis, visualization, and cross-platform application development. IDL is
specifically designed for the visualization and analysis of large, multi-dimensional
technical datasets. IDL is the language of choice for technical professionals, offering
simple syntax, array-oriented architecture, and rich library of analysis and
visualization routines.

HiRISE Overview

The HIiRISE (High Resolution Imaging Science Experiment) camera is a science
instrument on board the MRO (Mars Reconnaissance Orbiter) spacecraft platform.
Ball Aerospace designed and built the HiRISE instrument for the MRO mission, while
the spacecraft bus design was performed by Lockheed Martin and the Jet Propulsion
Laboratory. The MRO spacecraft was launched in August of 2005 and settled into its
final orbit around Mars during the fall of 2006 for the start of the primary science
phase of its mission.

The HIRISE instrument acquires data with unprecedented image quality, resolution,
and coverage, providing both panchromatic and color images. The camera produces
high spatial resolution images with 1 to 2 meters/pixel content. Consequently,
HiRISE will be used to investigate deposits and landforms resulting from geologic and
climatic processes and assist in the evaluation of candidate landing sites.

For more information, please visit the official HIRISE website at the University of
Arizona Lunar and Planetary Laboratory:

http://hirise.lpl.arizona.edu/
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Using ENVI with HIiRISE Image Data

Getting Started with ENVI

Installing the HIRISE Toolkit for ENVI

In an effort to provide support to the planetary scientists working with HIRISE RDR
(Reduced Data Record) image data, a custom toolkit has been developed by ITT
Visual Information Solutions as an extension to the ENVI software package. This
toolkit is distributed as a plugin to ENVI that adds the following functionality to the
software package:

Custom data input utility for PDS .JP2, PDS .IMG, JPEG, PNG, TIFF
Support for PDS attached and detached label (*.LBL) files

Input of Mars map projection metadata

Interactive PDS metadata viewer

Automatic band center wavelength & FWHM designation

Custom cursor location tool that displays both planetocentric and
planetographic coordinates

e Calibration to I/F utility

In order to utilize this toolkit you must have access to a licensed copy of ENVI v.4.3
or newer. To download and install this toolkit simply visit the following webpage,
download the ZIP file, unpack, and follow the instructions in the "README.txt" file:

http://www.ittvis.com/Downloads/toolkits.aspx

Starting the ENVI Software

Before attempting to start the software program, please ensure that ENVI is properly
installed as described in the Installing and Licensing ENVI documentation manual
included with the software on data CD-ROM #3.

Starting ENVI on Windows
e For ENVI Runtime, select Start > All Programs > ENVI #.# > ENVI.
e For ENVI+IDL, select Start > All Programs > ENVI #.# > ENVI+IDL.

Starting ENVI on UNIX & Linux
e For ENVI Runtime, enter envi_rt at the UNIX command line.
e For ENVI+IDL, enter envi at the UNIX command line.
e NOTE: If these commands do not produce the expected results, you need to
set ENVI environment aliases. Please consult the “Setting Up the ENVI
Environment” section of the Installing and Licensing ENVI manual.
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Starting ENVI on Macintosh
e ENVI for Mac OS X can be run one of two ways:

1. From an Applescript application. To launch the software simply click on
the appropriate icon in the /Applications/itt/idl# #/ directory.

2. From a UNIX X-Windows prompt. First launch X11 from the
Applications folder. X11 displays a UNIX X-Windows command line in
an OS X window:

= For ENVI Runtime, enter envi_rt at the UNIX command line.

= For ENVI+IDL, enter envi at the UNIX command line.

= NOTE: If these commands do not produce the expected results,
you need to set ENVI environment aliases. Please consult the
“Setting Up the ENVI Environment” section of the Installing and
Licensing ENVI manual.

Importing a HIRISE RDR Dataset

Once the HIRISE Toolkit for ENVI has been installed as described above, 3 new menu
options and a display utility will be added to the software package:

1. File -2 Open External File > MRO > HiRISE RDR
e Use this utility to open the HIRISE datasets. This menu option should be
used when opening HIiRISE images in PDS .JP2, PDS .IMG, JPEG, PNG, and
TIFF file formats.

2. File > Open External File > MRO - View PDS Metadata
e Use this utility to view the PDS metadata in an interactive viewer.

3. Basic Tools - Calibrate HiRISE to I/F
e Use this utility to apply the scaling factor & offset.

4. Within a main image or zoom display window of HiRISE data, you can click-
and-drag with the middle mouse button and see a custom cursor location
dialog that display both planetocentric and planetographic coordinates. This
utility does not work within the Scroll window as the middle mouse button
performs the meta scroll functionality.

In order to import a HIRISE RDR dataset into the ENVI software package, simply
select “File - Open External File > MRO > HiRISE RDR" from the main ENVI
menu [Fig. 1] and select the desired image file. The image data will be automatically
loaded into the Available Bands List and an image display group within the ENVI
software package.
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Figure 1: The main ENVI menu system
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Working with HiRISE Data

Familiarizing Yourself with the ENVI Interface

When a HIiRISE image is opened using the “File - Open External File »> MRO >
HIiRISE RDR"” menu option the contents of the dataset will be listed in the Available
Bands List dialog [Fig. 2] and the image will be displayed within a display window

group [Fig. 3].

i#l Available Bands List - 10| x|
Filename - ,
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E--Eij FPSP_001367_1620 RED.JPZ2
Rl -0 (70000001 8 S Band Name
-8 Map Info B &
Map E F'.n:ui: Equirectangular Wavelength
Projection \\ ----- O Pixel: 0.25 Meters
Metadata pe Daturn: Mare 2001
----- 0 UL Geo: 160°8"'94.13", 17°37'23.98"'S
fen L Map: -3222 750, 1044617375
(% GrapScale  RGE Color ——u | Display
| Controls
Selected Band
IHE D (7O0.0000):PSP_001367_1620_RED.JF2
Dimensions
Data Type > Dims|2559lil % 43115 [Unsigned Int) [B50]
Interleave n Load Image
LoadBand | Display #1effe————— | Band(s)

Figure 2: The Available Bands List

The ENVI display group consists of 3 separate windows that can be used to explore
large images [Fig. 3]:

e Main (1:1 scale) image window
e Scroll (thumbnail) window
e Zoom (magnified) window
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Figure 3: An image display group

The main image display window has its own menubar and display the imagery at 1:1
full resolution. Within the main image window is a zoom box that can be moved
using the mouse which controls the location and content of the zoom window. In the
lower-left hand corner of the zoom window are the controls for increasing and
decreasing magnification, along with the crosshair toggle. The scroll window displays
a thumbnail of the entire image subsampled down to a low resolution, and contains a
box that controls the location of the main image window.
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Using ENVI with HIiRISE Image Data

All three windows in the display group can be moved and resized, and each will
display a context menu with additional utilities and options when you right-click
within the window [Fig. 4].

Link Displays. ..
Geographic Link.. .

Z Profile (Spectrumy, ..,
ROT Tool, ..
Interactive Strekching. ..

Save Image As...
Save Zoom As...

Cursor Location)Yalue, .
Pixel Locatar. ..

Quick Skats. .,

Toggle »

Display Window Style b
ScrollfZoom Position »

<Find Display =

Figure 4: Context menu obtained via right-click within display windows

A useful utility for exploring imagery that is built into the ENVI software package is
the cursor location / value dialog. This tool can be launched by performing one of the
following operations:

e Double-click within the main image window
¢ Right-click within any window and select “Cursor Location/Value...”
e Select “Tools 2 Cursor Location/Value...” from the display menu

The cursor location / value utility displays the current mouse cursor location
(column, row), along with the screen display intensities, map projection, geolocation
in both map coordinates and latitude & longitude, and pixel data value [Fig. 5].

@ Cursor Location / Yalue - 10| x|

File Cptions

Digp #1 [13358,30587) Scin: B:136 G:136 B:136
Projection: E quirectangular

Map: 116.50E -1052263. 885 Meters

LL : 17°45'8.38"5, 1607631 . 32

Data: 28153

Figure 5: The cursor location / value utility

This dialog will automatically update as you move the mouse cursor within any of the
3 image display windows.
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Using the HIiRISE Toolkit Utilities

In addition to the ability to input and display images from HiRISE RDR datasets, the
HIRISE Toolkit for ENVI also provides a custom cursor location dialog that displays
map coordinates in both planetocentric and planetographic systems. The
planetocentric coordinates are essentially the same as those reported by ENVI's
cursor location / value utility, but the planetographic are slightly different depending
upon the latitude of the image. This custom cursor location tool only works with PDS
format datasets.

In order to utilize the HIRISE Cursor Location utility, simply press the middle mouse
button and hold it down while you move the mouse cursor (i.e. click-and-drag) in
either the main image or zoom windows [Fig. 6].

HIRISE Cursor Location

File = "PSP_001367 1620 RED.JP2"
Image Pixel ¥,Y¥ (COL,ROW) = (13546,30645)

FPlanetocentric (LON,LAT) {199.908755344,-17.752572665)
Flanetographic (LON,LAT) (-160.091241656,-17.949959773 )

Figure 6: The HiRISE cursor location utility

Another utility included with the H/RISE Toolkit for ENVI provides a calibration
conversion of the image to I/F units by applying the scaling factor (i.e. gain) and
offset parameters found within the metadata of PDS format datasets. To run this tool
simply select “Basic Tools > Calibrate HIiRISE to I/F” from the main ENVI menu,
select a previously opened HiRISE dataset and specify any desired subsetting, then
specify a new output file to create on disk. The resulting dataset should be
automatically loaded into the software and displayed.

The final component of the HIRISE Toolkit for ENVI is an interactive dialog for
viewing the metadata from PDS format labels. To use this utility simply select “File
- Open External File > MRO - View PDS Metadata” from the main ENVI menu
and select a PDS format dataset. The metadata from the PDS label will be loaded
into a tree format graphical user interface [Fig. 7].
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Figure 7: The PDS metadata viewer
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Image Exploration and Analysis Tools

There are a number of tools built into the ENVI main image display menu that can be
useful for exploring and analyzing HiRISE datasets. The Enhance menu contains a
number of tools that are useful for controlling the appearance of the imagery. Within
this menu are a number of filters that can be applied to the image in order to
sharpen or smooth the image. Furthermore, there are a number of pre-built
stretches that can be applied based on the contents of any of the 3 image display
windows (Image, Zoom, or Scroll). For example, a gaussian stretch can be applied to
the image based on the histogram content of the entire image dataset by selecting
“Enhance > [Scroll] Gaussian” [Fig. 8].

Figure 8: HIRISE image display with gaussian stretch applied

In addition, there is an interactive histogram manipulation tool that can be accessed
by selecting “Enhance > Interactive Stretching...”.

A quick and easy way to move the active cursor within the center crosshairs of the
zoom window to a specific geographic location can be obtained by selecting “Tools 2>
Pixel Locator...” from the image display menu. This will display the Pixel Locator
dialog, within which you can enter a map coordinate in either easting & northing or
longitude & latitude by pressing the toggle button [Fig. 9].
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Figure 9: The pixel locator tool

Once you press the Apply button within the Pixel Locator dialog the image display
will move to center the zoom window on the desired geolocation.

Another utility that may be useful is the measurement tool, which allows you to draw
line segments on any of the 3 display windows and see a report of the distance in a
wide variety of units. In order to utilize this tool, simply select “Tools >
Measurement Tool...” from the image display menu. The Display Measurement
Tool dialog will be displayed, within which you can select the active display window
and the units to report (e.g. “"Units > Meters”). Once this is accomplished, use the
mouse to click between the points in order to measure the distance of the line
segments [Fig. 10]. To complete the segments or start a new line simply click using
the right mouse button.

&l Display Measurement Tool ;[Qlil

Select \iFile Type Units Area  Opkions
Active
. ‘I ~
Display D'SF"E'&'I_  Image  Scroll ¢ Zoom ( Of
Window _
Total Dist: 110.4044 eters

Segment #1: 110.4044 Meters =]

i o

Figure 10: The display measurement tool
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A tool is also available for extracting arbitrary line profiles (i.e. transects) of the
image data. This utility can be accessed by selecting “Tools = Profiles > Arbitrary
Profile (Transect)...” from the display menu. This will display the Spatial Profile
Tool dialog. Once again, you can choose to extract a line profile from any of the
three image display windows.

In order to use the spatial profile tool, simply draw a line using the left mouse button
within the active display window, then click the right mouse button twice in order to
complete and extract the profile. The line profile of the data values for the pixels
across the transect will be displayed within a separate line plot dialog [Fig. 11].

# #1:5patial Profile #1 =10] =]

File Edit ©ptions Plot_Function Help

Spatial Profile

1000

Figure 11: The arbitrary spatial profile tool

One final utility that can be very useful when working with images is the ROI (region
of interest) tool built into the ENVI software package. To access the ROI Tool, simply
select “Tools - Region Of Interest - ROI Tool...” from the image display menu.
This will launch the ROI Tool dialog, within which you can control the active window
and type of ROI being defined using the ROI_Type menu.

A common task that can be performed using the ROI Tool is to use the mouse to
draw a ROI on the image, then compute the area of this region in a wide variety of
units. This can be accomplished by defining the ROI using the left button on the
mouse then select "Options - Report Area of ROIs...” from the ROI Tool/ menu
[Fig. 12].

=

File:
I Fegion #1: 1.565.750 Meters*®

Figure 12: The ROI area information dialog
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Conclusion

Using ENVI with other Mars Datasets

ITT Visual Information Solutions recognizes the increased focus towards the
exploration and analysis of the other planets in our solar system, and the challenges
planetary scientists face when processing that large amounts of data that is
becoming available. In addition to the HIiRISE instrument, the Mars Reconnaissance
Orbiter has other instruments that acquire imagery such as CRISM (Compact
Reconnaissance Imaging Spectrometer for Mars), CTX (Context Camera), and MARCI
(Mars Color Imager). ENVI’s rich suite of image processing and spectral analysis
tools make it an excellent software package for the analysis of these datasets.

Furthermore, other raster datasets from previous missions such as the MOLA (Mars
Orbiter Laser Altimeter) science investigation can be analyzed using ENVI. In fact, if
a dataset is stored in the PDS file format you may be able to open it using the “File
-2 Open External File > MRO > HIiRISE RDR" option from the HIRISE Toolkit for
ENVI in order to input the data into the software. A common visualization technique
applied to DEM data is the creation of a hill shade image, which uses a combination
of shaded relief and a color table to display the topography [Fig. 13].

ﬂ #1 Scroll [(0.02633)

Figure 13: Hill shade image of MOLA DEM data input using HiRISE Toolkit
To learn more about ENVI’s functionality please visit:

http://www.ittvis.com/ProductServices/ENVI.aspx

Or contact your ENVI sales representative at (303)-786-9900 <info@ittvis.com>.
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